PP2K Fault Codes
#1
Hi guys,

 its almost mot time for my car and while iv been fixing other bits and bobs i realized the EML and Airbag light and a few others either didn't work or had the bulb removed lol -_- 

so i replaced them and wasn't surprised when the EML and Airbag light was on so i bought Diagbox and got it hooked up and done a global test got a load of intermittent codes on the engine ecu so i cleared them and only 2 "permanent faults" remained.

I also cleared codes from the Airbag ECU and the BSI and the ABS light has always worked properly and PP2K confirmed no faults with the ABS.

Engine ECU Faults:
- Airflow meter open circuit or short, Flow too low. Permanent Fault
- Pre/post heating relay circuit, Open relay. Permanent Fault

BSI Faults:
- No reply engine management control unit. Permanent Fault
- Locking failure caused by left hand door latch. Intermittent Fault
- Locking failure caused by right hand door latch. Intermittent Fault

Airbag ECU Faults:
- Drivers module trigger, Open circuit. Permanent Fault
- Seat belt trigger (right) , Open circuit. Permanent Fault
- Front right side airbag ignition module fault. Permanent Fault
FIXED - Seat belt trigger (left) , Open circuit. Permanent Fault
FIXED - Left side module ignition module, Open circuit. Permanent Fault

The EML is off after clearing codes but the Airbag light is still on.

The car runs fine just had new oil , oil filter , fuel filter , cleaned lift pump filter and flushed out the radiator i have also plugged the vac pipe to the egr + doser from the servo to disable them and decat pipe.

Now the only engine problem i have is when starting the car i usually turn the key for a second and the car started that way since i bought it almost 4 years ago but recently it takes a bit longer to start i have to hold the key longer to keep the starter spinning and it starts and runs fine also ive noticed if i try and start it like i used to it will start every second try ... like ill hold the key for a second and hear the engine turn over and kind of not "ignite" so ill release the key and then turn the key again for second and this time it starts like normal but it is consistant.

Anyways i am more bothered about the BSI and Airbag faults at the moment as i really want my central locking to work again and id like my airbags to work although i hope i never see them go off Wink So my central locking doesnt work , the RF remote doesnt work ive replaced the battery and still nothing , i have to open each door by hand like a car without central locking but when i open the drivers or passenger side door with the key it also opens the boot as usual so the boot seems unaffected any ideas based on the codes from PP2K ? 

Thanks for any help guys :Smile
Reply
Thanks given by:
#2
(06-07-2018, 09:32 PM)Smokey Smokes Wrote: Hi guys,

 its almost mot time for my car and while iv been fixing other bits and bobs i realized the EML and Airbag light and a few others either didn't work or had the bulb removed lol -_- 

so i replaced them and wasn't surprised when the EML and Airbag light was on so i bought Diagbox and got it hooked up and done a global test got a load of intermittent codes on the engine ecu so i cleared them and only 2 "permanent faults" remained.

I also cleared codes from the Airbag ECU and the BSI and the ABS light has always worked properly and PP2K confirmed no faults with the ABS.

Engine ECU Faults:
- Airflow meter open circuit or short, Flow too low. Permanent Fault
- Pre/post heating relay circuit, Open relay. Permanent Fault

BSI Faults:
- No reply engine management control unit. Permanent Fault
- Locking failure caused by left hand door latch. Intermittent Fault

Airbag ECU Faults:
- Drivers module trigger, Open circuit. Permanent Fault
- Seat belt trigger (left) , Open circuit. Permanent Fault
- Seat belt trigger (right) , Open circuit. Permanent Fault
- Left side module ignition module, Open circuit. Permanent Fault
- Front right side airbag ignition module fault. Permanent Fault

The EML is off after clearing codes but the Airbag light is still on.

The car runs fine just had new oil , oil filter , fuel filter , cleaned lift pump filter and flushed out the radiator i have also plugged the vac pipe to the egr + doser from the servo to disable them and decat pipe.

Now the only engine problem i have is when starting the car i usually turn the key for a second and the car started that way since i bought it almost 4 years ago but recently it takes a bit longer to start i have to hold the key longer to keep the starter spinning and it starts and runs fine also ive noticed if i try and start it like i used to it will start every second try ... like ill hold the key for a second and hear the engine turn over and kind of not "ignite" so ill release the key and then turn the key again for second and this time it starts like normal but it is consistant.

Anyways i am more bothered about the BSI and Airbag faults at the moment as i really want my central locking to work again and id like my airbags to work although i hope i never see them go off Wink So my central locking doesnt work , the RF remote doesnt work ive replaced the battery and still nothing , i have to open each door by hand like a car without central locking but when i open the drivers or passenger side door with the key it also opens the boot as usual so the boot seems unaffected any ideas based on the codes from PP2K ? 

Thanks for any help guys :Smile
Update , ive fixed 2 airbag faults - Seat belt trigger (left) , Open circuit. Permanent Fault and Left side module ignition module, Open circuit. Permanent Fault.

It was the wires under the front passenger seat, one of the wires was totally snapped and a few other wires had damaged rubber and exposed wires so i cut them out and replaced with new longer lengths cleared airbag codes on pp and only 3 remain.

With the central locking ive took out the center console and have access to the central locking ecu and ive removed the door trim also to get access to the wiring and locks ive unplugged the connectors to the locks and the connector from the car to the door and checked the wires with a multimeter it seems one of the pins on the lock connector connects to 2 pins on the door connector but only on the drivers door ... maybe this is how its supposed to be idk? .... another fault popped up in BSI saying - Locking failure caused by right hand door latch. Intermittent Fault so maybe both locks are faulty idk lol ?
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
  PP2K and DAM help Piggy 10 983 03-07-2016, 09:35 PM
Last Post: BiG K
  Who's the genius with pp2k? thebluepearl 6 473 02-06-2016, 07:19 AM
Last Post: thebluepearl

Forum Jump:


Users browsing this thread: 2 Guest(s)