Strut Top Bearing?
#1
Afternoon all! 

Had some new tyres fitted today, and as the chap was torqing the bolts we said there was "forward movement" with the wheel. 

Am I right in thinking this is the strut top bearing? 

There's no noticable noise (that I can hear over the knackered rear axle!) And no noticable handling issues. 


Any pointers would be great! 

Cheers all



Rob
Reply
Thanks given by:
#2
It'll probably be worn/old P bushes on the lower arms, they allow this movement.

Totally normal if they're a bit old, in fact the wheels will still move a little even with new lower arms.

Failing strut tops are noisy/grinding/pinging when turning lock to lock.
A moments silence please, for our brothers in the NAD-zone.
Reply
Thanks given by:
#3
Brilliant thanks for the tip. It's done 153k so I wouldn't be surprised!

Is this something that will need addressing asap or can it wait dor the winter rebuild I have planned?
Reply
Thanks given by:
#4
(14-06-2018, 04:41 PM)KernowViking Wrote: Brilliant thanks for the tip. It's done 153k so I wouldn't be surprised!

Is this something that will need addressing asap or can it wait dor the winter rebuild I have planned?

Well... it can't fall off  Rofl
A moments silence please, for our brothers in the NAD-zone.
Reply
Thanks given by: KernowViking
#5
All the news I need!  Rofl
Reply
Thanks given by:


Possibly Related Threads...
Thread Author Replies Views Last Post
  FRONT STRUT TOP MOUNT BEARING procta 1 489 27-02-2016, 07:15 PM
Last Post: welshpug

Forum Jump:


Users browsing this thread: 1 Guest(s)