Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Clock and temperature display.
#1
My clock back lighting is not working, I have changed the two bulbs but they don't light up, the clock is working just the globes don't light up. Does this mean I have to get another clock or is there something else I can do? Thanks.[/u]
Reply
Thanks given by:
#2
Sounds more like the illumination wire has broken somewhere, would check to see if that's got voltage before replacing the clock.
Reply
Thanks given by:
#3
Thanks I will check it.
Reply
Thanks given by:
#4
don't know what Tom's on about, it will be the bulbs that have blown, 99.9% sure lol . . . . .just replace them . Smile
Phase 1 D-Turdo, K14@24 psi, De-cat, meaty backbox, Bosch pump, grinded LDA pin, duel air fed K&N =133.7bhp & 188ft/lbs
Reply
Thanks given by:
#5
He's already changed the bulbs with no effect...
Reply
Thanks given by:
#6
(02-02-2014, 03:06 PM)Toms306 Wrote: He's already changed the bulbs with no effect...

sorry mate my bad, i'll give myself a warning. . .lol
Phase 1 D-Turdo, K14@24 psi, De-cat, meaty backbox, Bosch pump, grinded LDA pin, duel air fed K&N =133.7bhp & 188ft/lbs
Reply
Thanks given by:
#7
Haha, no worries. Tongue
Reply
Thanks given by:
#8
Are you using the right type of bulbs? If I remember correctly the bulbs in that display are not the same as others that size, the contacts are in a different place on the holders. I think that's why I ended up paying something like £7 per bulb from the dealers years ago.
Reply
Thanks given by:
#9
Try turning the bulb holders a bit
[Image: 00000000-0000-0000-0000-00000000014E_zpsprynorkl.jpg]
Reply
Thanks given by:
#10
Give it a slap they normally come on that way!!
Reply
Thanks given by:
#11
(02-02-2014, 10:07 PM)DeeTurbo Wrote: Are you using the right type of bulbs? If I remember correctly the bulbs in that display are not the same as others that size, the contacts are in a different place on the holders. I think that's why I ended up paying something like £7 per bulb from the dealers years ago.

Your right I got the wrong bulbs, at a glance they look right but they have different contacts. I will get the right ones and try them Thanks.
Reply
Thanks given by:
#12
Clock and temp gauge are working again, all I had to get was a couple of tiny globe inserts from the dealer, they gave me a refund on the ones that were wrong and the inserts only cost a couple of dollars, so it all turned out good. Thanks guys.
Reply
Thanks given by:
#13
Bastards, I asked for the holders and they said they only do the bulb and holders together that are soldered together so you can't just change the bulb.

Have you got a part number for what you got?
Reply
Thanks given by:
#14
1.2w wedge globe. Part No NG-5301. they just push into the black plastic holders.
Reply
Thanks given by:
#15
(02-02-2014, 10:28 PM)underground375 Wrote: Give it a slap they normally come on that way!!

Glad that's not just mine then!
Reply
Thanks given by:


Possibly Related Threads…
Thread Author Replies Views Last Post
  Intermittent Clock / Temp Display stevesmiff 6 1,104 15-01-2017, 10:51 AM
Last Post: cully
  CLOCK TIME DIGITAL TEMPERATURE GAUGE jlisarte 3 1,660 04-06-2013, 08:36 PM
Last Post: jlisarte
  Tempurature clock to non temp clock Ben Jay 10 2,716 28-02-2012, 09:48 AM
Last Post: Foxy-jim

Forum Jump:


Users browsing this thread: 1 Guest(s)